tocsin

PyPI/gitpython CVE-2026-73625: unknown, EPSS 0.92%

GitPython versions before 3.1.54 contain a remote code execution vulnerability in the check_unsafe_options guard that can be bypassed by smuggling git options inside single-character kwarg values. Att

Action: Upgrade gitpython to 3.1.54 or later.

pip install gitpython==3.1.54

Affected

introducedfixedlast affected
03.1.54-

Fixed versions

3.1.54

Sources

CVE-2026-73625 · published · modified · JSON