tocsin

PyPI/gitpython CVE-2026-67326: high 7.8, EPSS 0.25%

GitPython before 3.1.50 fails to validate newline characters in the section parameter of config_writer(), allowing attackers to inject arbitrary section headers into .git/config. Attackers can inject

Action: Upgrade gitpython to 3.1.50 or later.

pip install gitpython==3.1.50

Affected

introducedfixedlast affected
03.1.50-

Fixed versions

3.1.50

Sources

CVE-2026-67326 · published · modified · JSON