tocsin

PyPI/gitpython CVE-2026-87817: unknown, EPSS 0.42%

GitPython before 3.1.60 fails to properly validate the git directory location, allowing attackers to impersonate the git directory using tracked files like gitdir, commondir, and HEAD. Attackers can e

Action: Upgrade gitpython to 3.1.60 or later.

pip install gitpython==3.1.60

Affected

introducedfixedlast affected
03.1.60-

Fixed versions

3.1.60

Sources

CVE-2026-87817 · published · modified · JSON