tocsin

PyPI/gitpython CVE-2026-87819: high 7.5, EPSS 0.52%

GitPython before 3.1.60 contains a regular expression denial of service vulnerability in Actor.name_email_regex that processes commit author and committer fields. Attackers can craft a commit object w

Action: Upgrade gitpython to 3.1.60 or later.

pip install gitpython==3.1.60

Affected

introducedfixedlast affected
03.1.60-

Fixed versions

3.1.60

Sources

CVE-2026-87819 · published · modified · JSON