tocsin

PyPI/gitpython CVE-2026-73624: unknown, EPSS 0.55%

GitPython versions before 3.1.54 contain an arbitrary file overwrite vulnerability in the Diffable.diff method that fails to validate git options passed through kwargs. Attackers can supply the --outp

Action: Upgrade gitpython to 3.1.54 or later.

pip install gitpython==3.1.54

Affected

introducedfixedlast affected
03.1.54-

Fixed versions

3.1.54

Sources

CVE-2026-73624 · published · modified · JSON