PyPI/monai CVE-2026-100846: high 8.8, EPSS 0.36%
MONAI before 1.5.2 contains a deserialization of untrusted data vulnerability in the algo_from_pickle function in monai/auto3dseg/utils.py. The function reads a .pkl file and passes its contents to pi
Action: Upgrade monai to 1.5.2 or later.
pip install monai==1.5.2Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.5.2 | - |
Fixed versions
| 1.5.2 |
Sources
- osv: PYSEC-2026-4021
- https://www.vulncheck.com/advisories/monai-before-1.5.2-remote-code-execution-via-pickle-deserialization
- https://github.com/Project-MONAI/MONAI/security/advisories/GHSA-89gg-p5r5-q6r4
CVE-2026-100846 · published · modified · JSON