tocsin

PyPI/llama-index-vector-stores-duckdb CVE-2025-1750: critical 9.8, EPSS 0.82%

LlamaIndex DuckDBVectorStore vulnerable to SQL injection through ref_doc_id

Action: Upgrade llama-index-vector-stores-duckdb to 0.12.21 or later.

pip install llama-index-vector-stores-duckdb==0.12.21

Affected

introducedfixedlast affected
0.12.190.12.21-

Fixed versions

0.12.21

Sources

CVE-2025-1750 · published · modified · JSON