tocsin

PyPI/praisonai CVE-2026-40154: critical 9.3, EPSS 0.30%

PraisonAI Vulnerable Untrusted Remote Template Code Execution

Action: Upgrade praisonai to 4.5.128 or later.

pip install praisonai==4.5.128

Affected

introducedfixedlast affected
04.5.128-

Fixed versions

4.5.128

Sources

CVE-2026-40154 · published · modified · JSON