PyPI/praisonaiagents CVE-2026-40289: critical 9.1, EPSS 0.42%
PraisonAI Browser Server allows unauthenticated WebSocket clients to hijack connected extension sessions
Action: Upgrade praisonaiagents to 1.5.140 or later.
pip install praisonaiagents==1.5.140Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 1.5.140 | - |
Fixed versions
| 1.5.140 |
Sources
- osv: PYSEC-2026-485
- https://github.com/MervinPraison/PraisonAI/security/advisories/GHSA-8x8f-54wf-vv92
- https://nvd.nist.gov/vuln/detail/CVE-2026-40289
- https://github.com/MervinPraison/PraisonAI
- https://github.com/MervinPraison/PraisonAI/releases/tag/v4.5.139
- https://pypi.org/project/praisonaiagents
- https://github.com/advisories/GHSA-8x8f-54wf-vv92
CVE-2026-40289 · published · modified · JSON