PyPI/emmett CVE-2026-39847: high 7.5, EPSS 0.50%
Emmett is a full-stack Python web framework designed with simplicity. From 2.5.0 to before 2.8.1, the RSGI static handler for Emmett's internal assets (/__emmett__ paths) is vulnerable to path travers
Action: Upgrade emmett to 2.8.1 or later.
pip install emmett==2.8.1Affected
| introduced | fixed | last affected |
|---|---|---|
| 2.5.0 | 2.8.1 | - |
Fixed versions
| 2.8.1 |
Sources
- osv: PYSEC-2026-59
- https://github.com/emmett-framework/emmett/security/advisories/GHSA-pr46-2v3c-5356
CVE-2026-39847 · published · modified · JSON