tocsin

PyPI/chainlit CVE-2026-22218: medium 6.5, EPSS 9.72%

Chainlit versions prior to 2.9.4 contain an arbitrary file read vulnerability in the /project/element update flow. An authenticated client can send a custom Element with a user-controlled path value,

Action: Upgrade chainlit to 2.9.4 or later.

pip install chainlit==2.9.4

Affected

introducedfixedlast affected
02.9.4-

Fixed versions

2.9.4

Sources

CVE-2026-22218 · published · modified · JSON