PyPI/apache-airflow CVE-2025-68438: high 7.5, EPSS 0.62%
In Apache Airflow versions before 3.1.6, when rendered template fields in a Dag exceed [core] max_templated_field_length, sensitive values could be exposed in cleartext in the Rendered Templates UI. T
Action: Upgrade apache-airflow to 3.1.6 or later.
pip install apache-airflow==3.1.6Affected
| introduced | fixed | last affected |
|---|---|---|
| 3.1.0 | 3.1.6 | - |
Fixed versions
| 3.1.6 |
Sources
- osv: PYSEC-2026-9
- http://www.openwall.com/lists/oss-security/2026/01/15/5
- https://lists.apache.org/thread/55n7b4nlsz3vo5n4h5lrj9bfsk8ctyff
- https://github.com/advisories/GHSA-3qmm-r55x-hpxx
CVE-2025-68438 · published · modified · JSON