tocsin

PyPI/pymatgen CVE-2022-42964: medium 5.9, EPSS 0.88%

pymatgen is vulnerable to Regular Expression Denial of Service (ReDoS)

Action: Upgrade pymatgen to 2025.10.7 or later.

pip install pymatgen==2025.10.7

Affected

introducedfixedlast affected
02025.10.7-

Fixed versions

2025.10.7

Sources

CVE-2022-42964 · published · modified · JSON