tocsin

PyPI/sanic CVE-2022-35920: high 8.3, EPSS 1.20%

sanic vulnerable to Path Traversal when using `app.static` if using encoded `%2F` URLs

Action: Upgrade sanic to 20.12.7 or later.

pip install sanic==20.12.7
pip install sanic==22.6.1
pip install sanic==21.12.2

Affected

introducedfixedlast affected
020.12.7-
21.0.021.12.2-
22.0.022.6.1-

Fixed versions

20.12.722.6.121.12.2

Sources

CVE-2022-35920 · published · modified · JSON