PyPI/mlflow CVE-2026-33865: medium 5.4, EPSS 0.22%
MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface. An authenticated attacker can upload a malicious MLmodel file c
Action: Upgrade mlflow to 3.11.0rc0 or later.
pip install mlflow==3.11.0rc0Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 3.11.0rc0 | - |
Fixed versions
| 3.11.0rc0 |
Sources
- osv: PYSEC-2026-93
- https://cert.pl/en/posts/2026/04/CVE-2026-33865/
- https://github.com/mlflow/mlflow/pull/21435
- https://afine.com/blogs/attacking-mlflow-how-ml-artifacts-become-attack-vectors
- https://github.com/advisories/GHSA-fh64-r2vc-xvhr
CVE-2026-33865 · published · modified · JSON