tocsin

PyPI/brotlicffi CVE-2026-111497: critical 9.2, exploited, EPSS 82.64%

Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

Action: Upgrade brotlicffi to 1.2.1.0 or later.

pip install brotlicffi==1.2.1.0

Affected

introducedfixedlast affected
1.0.31.2.1.0-

Fixed versions

1.2.1.0

Sources

CVE-2026-111497 · published · modified · JSON