Debian/pygments: high 7.5
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity an
Action: Upgrade pygments to 2.7.1+dfsg-2.1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.1+dfsg-2.1 | - |
Fixed versions
| 2.7.1+dfsg-2.1 |
Sources
- osv: DEBIAN-CVE-2021-27291#Debian:14/pygments
- https://security-tracker.debian.org/tracker/CVE-2021-27291
published · modified · JSON