Debian/node-ua-parser-js: high 7.5
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing
Action: Upgrade node-ua-parser-js to 0.7.24+ds-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.7.24+ds-1 | - |
Fixed versions
| 0.7.24+ds-1 |
Sources
published · modified · JSON