Alpine/postgresql17: high 8.8
Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.1
Action: Upgrade postgresql17 to 17.8-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 17.8-r0 | - |
Fixed versions
| 17.8-r0 |
Sources
- osv: ALPINE-CVE-2026-2005#Alpine:v3.21/postgresql17
- https://security.alpinelinux.org/vuln/CVE-2026-2005
published · modified · JSON