Debian/node-sanitize-html: high 7.5
The package sanitize-html before 2.7.1 are vulnerable to Regular Expression Denial of Service (ReDoS) due to insecure global regular expression replacement logic of HTML comment removal.
Action: Upgrade node-sanitize-html to 2.7.1+~2.6.2-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.7.1+~2.6.2-1 | - |
Fixed versions
| 2.7.1+~2.6.2-1 |
Sources
- osv: DEBIAN-CVE-2022-25887#Debian:13/node-sanitize-html
- https://security-tracker.debian.org/tracker/CVE-2022-25887
published · modified · JSON