Debian/node-ip: critical 9.8
The ip package before 1.1.9 for Node.js might allow SSRF because some IP addresses (such as 0x7f.1) are improperly categorized as globally routable via isPublic.
Action: Upgrade node-ip to 2.0.1+~1.1.3-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.0.1+~1.1.3-1 | - |
Fixed versions
| 2.0.1+~1.1.3-1 |
Sources
- osv: DEBIAN-CVE-2023-42282#Debian:13/node-ip
- https://security-tracker.debian.org/tracker/CVE-2023-42282
published · modified · JSON