Debian/node-micromatch: medium 5.3
The NPM package `micromatch` prior to 4.0.8 is vulnerable to Regular Expression Denial of Service (ReDoS). The vulnerability occurs in `micromatch.braces()` in `index.js` because the pattern `.*` will
Action: Upgrade node-micromatch to 4.0.7+~4.0.7-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.0.7+~4.0.7-1 | - |
Fixed versions
| 4.0.7+~4.0.7-1 |
Sources
- osv: DEBIAN-CVE-2024-4067#Debian:13/node-micromatch
- https://security-tracker.debian.org/tracker/CVE-2024-4067
published · modified · JSON