Debian/node-serve-static: medium 4.7
serve-static serves static files. serve-static passes untrusted user input - even after sanitizing it - to redirect() may execute untrusted code. This issue is patched in serve-static 1.16.0.
Action: Upgrade node-serve-static to 2.1.0+~1.15.7-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2.1.0+~1.15.7-1 | - |
Fixed versions
| 2.1.0+~1.15.7-1 |
Sources
- osv: DEBIAN-CVE-2024-43800#Debian:13/node-serve-static
- https://security-tracker.debian.org/tracker/CVE-2024-43800
published · modified · JSON