Debian/rust-pgp: high 7.5
rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows an attacker to trigger rpgp crashes by providing crafted data. This vulnerability is fixed in 0.14.1.
Action: Upgrade rust-pgp to 0.14.2-1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.14.2-1 | - |
Fixed versions
| 0.14.2-1 |
Sources
- osv: DEBIAN-CVE-2024-53856#Debian:14/rust-pgp
- https://security-tracker.debian.org/tracker/CVE-2024-53856
published · modified · JSON