Debian/patool: unknown
Patool before 4.0.5 contains a path traversal vulnerability in the safe_extract() function in patoolib/programs/py_tarfile.py when running on Python before 3.12, where the is_within_directory() helper
Action: Upgrade patool to 4.0.5-0.1 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.0.5-0.1 | - |
Fixed versions
| 4.0.5-0.1 |
Sources
- osv: DEBIAN-CVE-2026-29509#Debian:14/patool
- https://security-tracker.debian.org/tracker/CVE-2026-29509
published · modified · JSON