Debian/swupdate: high 7.5
A weakness has been identified in Cesanta Mongoose up to 7.20. This vulnerability affects the function handle_opt of the file /src/net_builtin.c of the component TCP Option Handler. This manipulation
Action: Upgrade swupdate to 2025.12+dfsg-10 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 2025.12+dfsg-10 | - |
Fixed versions
| 2025.12+dfsg-10 |
Sources
- osv: DEBIAN-CVE-2026-6985#Debian:14/swupdate
- https://security-tracker.debian.org/tracker/CVE-2026-6985
published · modified · JSON