Alpine/pdns-recursor: high 7.5
PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed reco
Action: Upgrade pdns-recursor to 4.0.9-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 4.0.9-r0 | - |
Fixed versions
| 4.0.9-r0 |
Sources
- osv: ALPINE-CVE-2018-10851#Alpine:v3.7/pdns-recursor
- https://security.alpinelinux.org/vuln/CVE-2018-10851
published · modified · JSON