Alpine/py3-ecdsa: critical 9.1
A flaw was found in all python-ecdsa versions before 0.13.3, where it did not correctly verify whether signatures used DER encoding. Without this verification, a malformed signature could be accepted,
Action: Upgrade py3-ecdsa to 0.13.3-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 0.13.3-r0 | - |
Fixed versions
| 0.13.3-r0 |
Sources
- osv: ALPINE-CVE-2019-14859#Alpine:v3.13/py3-ecdsa
- https://security.alpinelinux.org/vuln/CVE-2019-14859
published · modified · JSON