Alpine/nodejs-current: critical 9.8
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dn
Action: Upgrade nodejs-current to 16.11.1-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 16.11.1-r0 | - |
Fixed versions
| 16.11.1-r0 |
Sources
- osv: ALPINE-CVE-2021-22931#Alpine:v3.14/nodejs-current
- https://security.alpinelinux.org/vuln/CVE-2021-22931
published · modified · JSON