Alpine/openjdk17: high 7.5
The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.
Action: Upgrade openjdk17 to 17.0.4_p8-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 17.0.4_p8-r0 | - |
Fixed versions
| 17.0.4_p8-r0 |
Sources
- osv: ALPINE-CVE-2022-25647#Alpine:v3.17/openjdk17
- https://security.alpinelinux.org/vuln/CVE-2022-25647
published · modified · JSON