Alpine/nodejs-current: high 8.1
A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly
Action: Upgrade nodejs-current to 18.6.0-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 18.6.0-r0 | - |
Fixed versions
| 18.6.0-r0 |
Sources
- osv: ALPINE-CVE-2022-32212#Alpine:v3.20/nodejs-current
- https://security.alpinelinux.org/vuln/CVE-2022-32212
published · modified · JSON