Alpine/nodejs-current: medium 6.5
The llhttp parser <v14.20.1, <v16.17.1 and <v18.9.1 in the http module in Node.js does not correctly parse and validate Transfer-Encoding headers and can lead to HTTP Request Smuggling (HRS).
Action: Upgrade nodejs-current to 18.9.1-r0 or later.
Affected
| introduced | fixed | last affected |
|---|---|---|
| 0 | 18.9.1-r0 | - |
Fixed versions
| 18.9.1-r0 |
Sources
- osv: ALPINE-CVE-2022-32213#Alpine:v3.16/nodejs-current
- https://security.alpinelinux.org/vuln/CVE-2022-32213
published · modified · JSON