{"action":"Upgrade phlex to 1.0.1 or later.","affected":[{"fixed":"1.9.1","introduced":"1.9.0"},{"fixed":"1.8.2","introduced":"1.8.0"},{"fixed":"1.7.1","introduced":"1.7.0"},{"fixed":"1.6.2","introduced":"1.6.0"},{"fixed":"1.5.2","introduced":"1.5.0"},{"fixed":"1.4.1","introduced":"1.4.0"},{"fixed":"1.3.3","introduced":"1.3.0"},{"fixed":"1.2.2","introduced":"1.2.0"},{"fixed":"1.1.1","introduced":"1.1.0"},{"fixed":"1.0.1","introduced":"0"}],"component":"phlex","cve_ids":["CVE-2024-28199"],"ecosystem":"RubyGems","epss":0.00604,"exploited":false,"fixed_versions":["1.9.1","1.8.2","1.7.1","1.6.2","1.5.2","1.4.1","1.3.3","1.2.2","1.1.1","1.0.1"],"ghsa_id":"GHSA-242p-4v39-2v8g","id":"tcs_01M5KEFSKTR5W0QKBDW5RQYH00","modified_at":"2026-09-10T03:50:00.390202157Z","published_at":"2024-03-12T15:39:46Z","references":["https://osv.dev/vulnerability/GHSA-242p-4v39-2v8g","https://github.com/phlex-ruby/phlex/security/advisories/GHSA-242p-4v39-2v8g","https://nvd.nist.gov/vuln/detail/CVE-2024-28199","https://github.com/phlex-ruby/phlex/commit/aa50c604cdee1d0ce7ef068a4c66cbd5d43f96a1","https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy","https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline","https://github.com/phlex-ruby/phlex","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/phlex/CVE-2024-28199.yml"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-242p-4v39-2v8g","url":"https://osv.dev/vulnerability/GHSA-242p-4v39-2v8g"}],"summary":"Cross-site Scripting (XSS) possible with maliciously formed HTML attribute names and values in Phlex"}