{"action":"Upgrade nokogiri to 1.10.5 or later.","affected":[{"fixed":"1.10.5","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2019-18197"],"ecosystem":"RubyGems","epss":0.04446,"exploited":false,"fixed_versions":["1.10.5"],"ghsa_id":"GHSA-242x-7cm6-4w8j","id":"tcs_01M5KEFSRYWE2T0RXR16MD81N8","modified_at":"2026-06-09T10:22:03Z","published_at":"2022-05-24T16:59:28Z","references":["https://osv.dev/vulnerability/GHSA-242x-7cm6-4w8j","https://nvd.nist.gov/vuln/detail/CVE-2019-18197","https://github.com/sparklemotion/nokogiri/issues/1943","https://access.redhat.com/errata/RHSA-2020:0514","https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15746","https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15768","https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15914","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2019-18197.yml","https://github.com/sparklemotion/nokogiri","https://github.com/sparklemotion/nokogiri/blob/01ab95f3e37429ed8d3b380a8d2f73902eb325d9/CHANGELOG.md?plain=1#L934","https://gitlab.gnome.org/GNOME/libxslt/commit/2232473733b7313d67de8836ea3b29eec6e8e285","https://lists.debian.org/debian-lts-announce/2019/10/msg00037.html","https://security.netapp.com/advisory/ntap-20191031-0004","https://security.netapp.com/advisory/ntap-20200416-0004","https://usn.ubuntu.com/4164-1","https://www.oracle.com/security-alerts/cpuapr2020.html","http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00010.html","http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00015.html","http://lists.opensuse.org/opensuse-security-announce/2020-02/msg00025.html","http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00062.html","http://www.openwall.com/lists/oss-security/2019/11/17/2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-242x-7cm6-4w8j","url":"https://osv.dev/vulnerability/GHSA-242x-7cm6-4w8j"}],"summary":"Nokogiri affected by libxslt Use of Uninitialized Resource/Use After Free vulnerability"}