{"action":"Upgrade redis-store to 1.4.0 or later.","affected":[{"fixed":"1.4.0","introduced":"0"}],"component":"redis-store","cve_ids":["CVE-2017-1000248"],"ecosystem":"RubyGems","epss":0.01983,"exploited":false,"fixed_versions":["1.4.0"],"ghsa_id":"GHSA-2w67-526p-gm73","id":"tcs_01M5KEG1ED6DFBR3JPCZS4ZXEZ","modified_at":"2024-02-16T08:24:25.597076Z","published_at":"2017-12-06T16:41:25Z","references":["https://osv.dev/vulnerability/GHSA-2w67-526p-gm73","https://nvd.nist.gov/vuln/detail/CVE-2017-1000248","https://github.com/redis-store/redis-store/commit/ce13252c26fcc40ed4935c9abfeb0ee0761e5704","https://github.com/redis-store/redis-store/commit/e0c1398d54a9661c8c70267c3a925ba6b192142e","https://github.com/redis-store/redis-store","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/redis-store/CVE-2017-1000248.yml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-2w67-526p-gm73","url":"https://osv.dev/vulnerability/GHSA-2w67-526p-gm73"}],"summary":"redis-store deserializes untrusted data"}