{"action":"Upgrade update_by_case to 0.1.3 or later.","affected":[{"fixed":"0.1.3","introduced":"0"}],"component":"update_by_case","cve_ids":["CVE-2022-35956"],"ecosystem":"RubyGems","epss":0.0063,"exploited":false,"fixed_versions":["0.1.3"],"ghsa_id":"GHSA-33wh-w4m7-c6r8","id":"tcs_01M5KEG5SMP9C50BEBQ249HFZ4","modified_at":"2023-11-08T04:09:54.202763Z","published_at":"2022-08-11T21:18:31Z","references":["https://osv.dev/vulnerability/GHSA-33wh-w4m7-c6r8","https://github.com/camilova/activerecord-update-by-case/security/advisories/GHSA-33wh-w4m7-c6r8","https://nvd.nist.gov/vuln/detail/CVE-2022-35956","https://github.com/camilova/activerecord-update-by-case","https://github.com/camilova/activerecord-update-by-case/releases/tag/v0.1.3-stable","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/update_by_case/CVE-2022-35956.yml"],"severity":{"label":"medium","score":5.8},"sources":[{"source":"osv","source_id":"GHSA-33wh-w4m7-c6r8","url":"https://osv.dev/vulnerability/GHSA-33wh-w4m7-c6r8"}],"summary":"update_by_case before 0.1.3 can be vulnerable to sql injection"}