{"action":"Upgrade netaddr to 1.5.3 or later.","affected":[{"fixed":"2.0.4","introduced":"2.0.0"},{"fixed":"1.5.3","introduced":"0"}],"component":"netaddr","cve_ids":["CVE-2019-17383"],"ecosystem":"RubyGems","epss":0.02351,"exploited":false,"fixed_versions":["2.0.4","1.5.3"],"ghsa_id":"GHSA-49pj-69vf-c689","id":"tcs_01M5KEGK0ZJ34V7HGG17KTGY3X","modified_at":"2024-10-23T17:46:12.681757Z","published_at":"2019-10-14T21:43:19Z","references":["https://osv.dev/vulnerability/GHSA-49pj-69vf-c689","https://nvd.nist.gov/vuln/detail/CVE-2019-17383","https://github.com/dspinhirne/netaddr-rb/issues/29","https://github.com/dspinhirne/netaddr-rb/pull/20","https://github.com/dspinhirne/netaddr-rb/commit/3aac46c00a36e71905eaa619cb94d45bff6e3b51","https://github.com/dspinhirne/netaddr-rb/commit/c7a7de39b7e1126aef11821f98970db18582948b","https://github.com/dspinhirne/netaddr-rb","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/netaddr/CVE-2019-17383.yml","https://rubygems.org/gems/netaddr/versions"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-49pj-69vf-c689","url":"https://osv.dev/vulnerability/GHSA-49pj-69vf-c689"}],"summary":"netaddr before 1.5.3 and 2.0.4 has Incorrect Default Permissions"}