{"action":"Upgrade espeak-ruby to 1.0.3 or later.","affected":[{"fixed":"1.0.3","introduced":"0"}],"component":"espeak-ruby","cve_ids":["CVE-2016-10193"],"ecosystem":"RubyGems","epss":0.02448,"exploited":false,"fixed_versions":["1.0.3"],"ghsa_id":"GHSA-4jm3-pfpf-h54p","id":"tcs_01M5KEGMT5ANET304AX4NGFBA5","modified_at":"2024-02-16T08:24:31.339878Z","published_at":"2017-10-24T18:33:35Z","references":["https://osv.dev/vulnerability/GHSA-4jm3-pfpf-h54p","https://nvd.nist.gov/vuln/detail/CVE-2016-10193","https://github.com/dejan/espeak-ruby/issues/7","https://github.com/dejan/espeak-ruby/commit/5251744b13bdd9fb0c72c612226e72d330bac143","https://github.com/dejan/espeak-ruby","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/espeak-ruby/CVE-2016-10193.yml","http://www.openwall.com/lists/oss-security/2017/01/31/14","http://www.openwall.com/lists/oss-security/2017/02/02/5"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-4jm3-pfpf-h54p","url":"https://osv.dev/vulnerability/GHSA-4jm3-pfpf-h54p"}],"summary":"espeak-ruby allows arbitrary command execution"}