{"action":"Upgrade ember-source to 1.2.2 or later.","affected":[{"fixed":"1.2.2","introduced":"1.2.0"},{"fixed":"1.3.2","introduced":"1.3.0"},{"fixed":"1.4.0.beta.6","introduced":"1.4.0.beta.1"}],"component":"ember-source","cve_ids":["CVE-2014-0046"],"ecosystem":"RubyGems","epss":0.01503,"exploited":false,"fixed_versions":["1.2.2","1.3.2","1.4.0.beta.6"],"ghsa_id":"GHSA-4q53-fqhc-cr46","id":"tcs_01M5KEGPJP4MXGM5XA2HZS6DG3","modified_at":"2025-08-11T16:25:36.506116Z","published_at":"2018-08-28T22:33:42Z","references":["https://osv.dev/vulnerability/GHSA-4q53-fqhc-cr46","https://nvd.nist.gov/vuln/detail/CVE-2014-0046","https://github.com/emberjs/ember.js/commit/45ee8df2a0efc0afe233d6b9b17045782a2e6b2d","https://github.com/emberjs/ember.js/commit/94b28b8773acf894c4d7d7fccf4411a706292436","https://github.com/emberjs/ember.js/commit/ab3199e68e1d0fc3c8f7f453cd38c51fe02af90b","https://exchange.xforce.ibmcloud.com/vulnerabilities/91242","https://github.com/emberjs/ember.js","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ember-source/CVE-2014-0046.yml","https://groups.google.com/forum/#!topic/ember-security/1h6FRgr8lXQ","http://emberjs.com/blog/2014/02/07/ember-security-releases.html","http://secunia.com/advisories/56965","http://www.openwall.com/lists/oss-security/2014/02/14/6","http://www.securityfocus.com/bid/65579"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-4q53-fqhc-cr46","url":"https://osv.dev/vulnerability/GHSA-4q53-fqhc-cr46"}],"summary":"ember-source Cross-site Scripting vulnerability"}