{"action":"Upgrade rexml to 3.3.2 or later.","affected":[{"fixed":"3.3.2","introduced":"0"}],"component":"rexml","cve_ids":["CVE-2024-39908"],"ecosystem":"RubyGems","epss":0.01493,"exploited":false,"fixed_versions":["3.3.2"],"ghsa_id":"GHSA-4xqq-m2hx-25v8","id":"tcs_01M5KEGRKN2ZZMBG831SJHGPEX","modified_at":"2026-09-10T03:50:16.309216229Z","published_at":"2024-07-16T19:49:15Z","references":["https://osv.dev/vulnerability/GHSA-4xqq-m2hx-25v8","https://github.com/ruby/rexml/security/advisories/GHSA-4xqq-m2hx-25v8","https://nvd.nist.gov/vuln/detail/CVE-2024-39908","https://github.com/ruby/rexml","https://github.com/ruby/rexml/releases/tag/v3.3.2","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rexml/CVE-2024-39908.yml","https://lists.debian.org/debian-lts-announce/2025/01/msg00011.html","https://security.netapp.com/advisory/ntap-20250117-0008","https://www.ruby-lang.org/en/news/2024/07/16/dos-rexml-cve-2024-39908"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-4xqq-m2hx-25v8","url":"https://osv.dev/vulnerability/GHSA-4xqq-m2hx-25v8"}],"summary":"REXML denial of service vulnerability"}