{"action":"Upgrade rack to 2.0.9.4 or later.","affected":[{"fixed":"3.0.9.1","introduced":"3.0.0"},{"fixed":"2.2.8.1","introduced":"2.2.0"},{"fixed":"2.1.4.4","introduced":"2.1.0"},{"fixed":"2.0.9.4","introduced":"0"}],"component":"rack","cve_ids":["CVE-2024-26146"],"ecosystem":"RubyGems","epss":0.01996,"exploited":false,"fixed_versions":["3.0.9.1","2.2.8.1","2.1.4.4","2.0.9.4"],"ghsa_id":"GHSA-54rr-7fvw-6x8f","id":"tcs_01M5KEGVFKRTEM7B1K1M6F6JHH","modified_at":"2026-09-10T03:50:05.329510159Z","published_at":"2024-02-28T22:57:03Z","references":["https://osv.dev/vulnerability/GHSA-54rr-7fvw-6x8f","https://github.com/rack/rack/security/advisories/GHSA-54rr-7fvw-6x8f","https://nvd.nist.gov/vuln/detail/CVE-2024-26146","https://github.com/rack/rack/commit/30b8e39a578b25d4bdcc082c1c52c6f164b59716","https://github.com/rack/rack/commit/6c5d90bdcec0949f7ba06db62fb740dab394b582","https://github.com/rack/rack/commit/a227cd793778c7c3a827d32808058571569cda6f","https://github.com/rack/rack/commit/e4c117749ba24a66f8ec5a08eddf68deeb425ccd","https://discuss.rubyonrails.org/t/possible-denial-of-service-vulnerability-in-rack-header-parsing/84942","https://github.com/rack/rack","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2024-26146.yml"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-54rr-7fvw-6x8f","url":"https://osv.dev/vulnerability/GHSA-54rr-7fvw-6x8f"}],"summary":"Rack Header Parsing leads to Possible Denial of Service Vulnerability"}