{"action":"Upgrade puppet to 2.7.21 or later.","affected":[{"fixed":"2.7.21","introduced":"2.7.0"},{"fixed":"3.1.1","introduced":"3.1.0"}],"component":"puppet","cve_ids":["CVE-2013-1655"],"ecosystem":"RubyGems","epss":0.04558,"exploited":false,"fixed_versions":["2.7.21","3.1.1"],"ghsa_id":"GHSA-574q-fxfj-wv6h","id":"tcs_01M5KEGW6C8CFTEN902ZVYD9C1","modified_at":"2024-11-29T05:41:52.534442Z","published_at":"2017-10-24T18:33:37Z","references":["https://osv.dev/vulnerability/GHSA-574q-fxfj-wv6h","https://nvd.nist.gov/vuln/detail/CVE-2013-1655","https://github.com/puppetlabs/puppet","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2013-1655.yml","https://puppetlabs.com/security/cve/cve-2013-1655","https://web.archive.org/web/20200228144801/http://www.securityfocus.com/bid/58442","https://www.puppet.com/security/cve/cve-2013-1655-unauthenticated-remote-code-execution-vulnerability","http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00004.html","http://lists.opensuse.org/opensuse-updates/2013-04/msg00056.html","http://ubuntu.com/usn/usn-1759-1","http://www.debian.org/security/2013/dsa-2643"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-574q-fxfj-wv6h","url":"https://osv.dev/vulnerability/GHSA-574q-fxfj-wv6h"}],"summary":"Puppet Improper Input Validation vulnerability"}