{"action":"Upgrade trilogy to 2.1.1 or later.","affected":[{"fixed":"2.1.1","introduced":"0"}],"component":"trilogy","cve_ids":["CVE-2022-31026"],"ecosystem":"RubyGems","epss":0.01094,"exploited":false,"fixed_versions":["2.1.1"],"ghsa_id":"GHSA-5g4r-2qhx-vqfm","id":"tcs_01M5KEH0CN8ADJM3X5377NSCWY","modified_at":"2023-11-08T04:09:23.087201Z","published_at":"2022-06-06T21:22:05Z","references":["https://osv.dev/vulnerability/GHSA-5g4r-2qhx-vqfm","https://github.com/github/trilogy/security/advisories/GHSA-5g4r-2qhx-vqfm","https://nvd.nist.gov/vuln/detail/CVE-2022-31026","https://github.com/github/trilogy/commit/6bed62789eaf119902b0fe247d2a91d56c31a962","https://github.com/github/trilogy","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/trilogy/CVE-2022-31026.yml"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-5g4r-2qhx-vqfm","url":"https://osv.dev/vulnerability/GHSA-5g4r-2qhx-vqfm"}],"summary":"Use of Uninitialized Variable in trilogy"}