{"action":"Upgrade rubygems-update to 1.8.23 or later.","affected":[{"fixed":"1.8.23","introduced":"0"}],"component":"rubygems-update","cve_ids":["CVE-2012-2126"],"ecosystem":"RubyGems","epss":0.01362,"exploited":false,"fixed_versions":["1.8.23"],"ghsa_id":"GHSA-5mgj-mvv8-46mw","id":"tcs_01M5KEH2MFA8MRQASE9NNTTAYF","modified_at":"2024-12-02T05:43:07.385148Z","published_at":"2022-05-17T04:54:47Z","references":["https://osv.dev/vulnerability/GHSA-5mgj-mvv8-46mw","https://nvd.nist.gov/vuln/detail/CVE-2012-2126","https://github.com/rubygems/rubygems/commit/d4c7eafb8efe1e13a7abf5be5a5b4548870b15b7","https://bugzilla.redhat.com/show_bug.cgi?id=814718","https://github.com/rubygems/rubygems","https://github.com/rubygems/rubygems/blob/1.8/History.txt","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2012-2126.yml","http://rhn.redhat.com/errata/RHSA-2013-1203.html","http://rhn.redhat.com/errata/RHSA-2013-1441.html","http://rhn.redhat.com/errata/RHSA-2013-1852.html","http://www.openwall.com/lists/oss-security/2012/04/20/24","http://www.ubuntu.com/usn/USN-1582-1"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-5mgj-mvv8-46mw","url":"https://osv.dev/vulnerability/GHSA-5mgj-mvv8-46mw"}],"summary":"RubyGems does not verify SSL certificate"}