{"action":"Upgrade httparty to 0.21.0 or later.","affected":[{"fixed":"0.21.0","introduced":"0"}],"component":"httparty","cve_ids":["CVE-2024-22049"],"ecosystem":"RubyGems","epss":0.0129,"exploited":false,"fixed_versions":["0.21.0"],"ghsa_id":"GHSA-5pq7-52mg-hr42","id":"tcs_01M5KEH39ETCD4RD2SJ6XCDFXY","modified_at":"2026-07-08T06:52:57.239413197Z","published_at":"2023-01-03T13:36:46Z","references":["https://osv.dev/vulnerability/GHSA-5pq7-52mg-hr42","https://github.com/jnunemaker/httparty/security/advisories/GHSA-5pq7-52mg-hr42","https://nvd.nist.gov/vuln/detail/CVE-2024-22049","https://github.com/jnunemaker/httparty/commit/cdb45a678c43e44570b4e73f84b1abeb5ec22b8e","https://github.com/jnunemaker/httparty","https://github.com/jnunemaker/httparty/blob/4416141d37fd71bdba4f37589ec265f55aa446ce/lib/httparty/request/body.rb#L43","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/httparty/CVE-2024-22049.yml"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-5pq7-52mg-hr42","url":"https://osv.dev/vulnerability/GHSA-5pq7-52mg-hr42"}],"summary":"httparty has multipart/form-data request tampering vulnerability"}