{"action":"Upgrade safemode to 1.3.2 or later.","affected":[{"fixed":"1.3.2","introduced":"0"}],"component":"safemode","cve_ids":["CVE-2017-7540"],"ecosystem":"RubyGems","epss":0.01627,"exploited":false,"fixed_versions":["1.3.2"],"ghsa_id":"GHSA-5vx5-9q73-wgp4","id":"tcs_01M5KEH4SXZ8N8S4YSPS9Z3E92","modified_at":"2024-02-16T08:16:32.843034Z","published_at":"2017-10-24T18:33:35Z","references":["https://osv.dev/vulnerability/GHSA-5vx5-9q73-wgp4","https://nvd.nist.gov/vuln/detail/CVE-2017-7540","https://github.com/svenfuchs/safemode/pull/23","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/safemode/CVE-2017-7540.yml","https://github.com/svenfuchs/safemode"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-5vx5-9q73-wgp4","url":"https://osv.dev/vulnerability/GHSA-5vx5-9q73-wgp4"}],"summary":"Safemode Gem Has Incomplete List of Disallowed Inputs"}