{"action":"Upgrade rack to 2.2.18 or later.","affected":[{"fixed":"2.2.18","introduced":"0"}],"component":"rack","cve_ids":["CVE-2025-59830"],"ecosystem":"RubyGems","epss":0.00573,"exploited":false,"fixed_versions":["2.2.18"],"ghsa_id":"GHSA-625h-95r8-8xpm","id":"tcs_01M5KEH5X2Q7Z442V65A5E60F2","modified_at":"2026-09-10T03:50:58.118464536Z","published_at":"2025-09-25T16:39:27Z","references":["https://osv.dev/vulnerability/GHSA-625h-95r8-8xpm","https://github.com/rack/rack/security/advisories/GHSA-625h-95r8-8xpm","https://nvd.nist.gov/vuln/detail/CVE-2025-59830","https://github.com/rack/rack/commit/54e4ffdd5affebcb0c015cc6ae74635c0831ed71","https://github.com/rack/rack"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-625h-95r8-8xpm","url":"https://osv.dev/vulnerability/GHSA-625h-95r8-8xpm"}],"summary":"Rack has an unsafe default in Rack::QueryParser allows params_limit bypass via semicolon-separated parameters"}