{"action":"Upgrade grpc to 1.53.0 or later.","affected":[{"fixed":"1.53.0","introduced":"1.51.0"}],"component":"grpc","cve_ids":["CVE-2023-1428"],"ecosystem":"RubyGems","epss":0.00406,"exploited":false,"fixed_versions":["1.53.0"],"ghsa_id":"GHSA-6628-q6j9-w8vg","id":"tcs_01M5KEH8484N2EFF9S7CR3Z74C","modified_at":"2026-09-10T03:49:54.880238612Z","published_at":"2023-07-06T21:15:08Z","references":["https://osv.dev/vulnerability/GHSA-6628-q6j9-w8vg","https://nvd.nist.gov/vuln/detail/CVE-2023-1428","https://github.com/grpc/grpc/issues/33463","https://github.com/grpc/grpc/commit/2485fa94bd8a723e5c977d55a3ce10b301b437f8","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-1428.yml"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-6628-q6j9-w8vg#RubyGems/grpc","url":"https://osv.dev/vulnerability/GHSA-6628-q6j9-w8vg"}],"summary":"gRPC Reachable Assertion issue"}