{"action":"Upgrade doorkeeper to 1.4.1 or later.","affected":[{"fixed":"1.4.1","introduced":"0"}],"component":"doorkeeper","cve_ids":["CVE-2014-8144"],"ecosystem":"RubyGems","epss":0.00654,"exploited":false,"fixed_versions":["1.4.1"],"ghsa_id":"GHSA-685w-vc84-wxcx","id":"tcs_01M5KEH8DTDJ6Q6YG8P5P8WHFF","modified_at":"2025-04-14T22:28:22.694822Z","published_at":"2018-09-17T21:55:22Z","references":["https://osv.dev/vulnerability/GHSA-685w-vc84-wxcx","https://nvd.nist.gov/vuln/detail/CVE-2014-8144","https://exchange.xforce.ibmcloud.com/vulnerabilities/99342","https://github.com/doorkeeper-gem/doorkeeper","https://github.com/doorkeeper-gem/doorkeeper/blob/master/CHANGELOG.md","http://seclists.org/oss-sec/2014/q4/1076"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-685w-vc84-wxcx","url":"https://osv.dev/vulnerability/GHSA-685w-vc84-wxcx"}],"summary":"Doorkeeper vulnerable to Cross-site Request Forgery"}