{"action":"Upgrade kubeclient to 4.9.3 or later.","affected":[{"fixed":"4.9.3","introduced":"0"}],"component":"kubeclient","cve_ids":["CVE-2022-0759"],"ecosystem":"RubyGems","epss":0.00942,"exploited":false,"fixed_versions":["4.9.3"],"ghsa_id":"GHSA-69p3-xp37-f692","id":"tcs_01M5KEH96M0QKD0QJTDKDFAZ0Q","modified_at":"2023-11-08T04:07:40.042374Z","published_at":"2022-03-26T00:00:29Z","references":["https://osv.dev/vulnerability/GHSA-69p3-xp37-f692","https://nvd.nist.gov/vuln/detail/CVE-2022-0759","https://github.com/ManageIQ/kubeclient/issues/554","https://github.com/ManageIQ/kubeclient/issues/555","https://github.com/ManageIQ/kubeclient/pull/556","https://github.com/ManageIQ/kubeclient/commit/109ea71de5a8881748f03ebbe103b49f0f1c7887","https://github.com/ManageIQ/kubeclient","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/kubeclient/CVE-2022-0759.yml"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-69p3-xp37-f692","url":"https://osv.dev/vulnerability/GHSA-69p3-xp37-f692"}],"summary":"Improper Certificate Validation in kubeclient"}